Tallan's Technology Blog

Tallan's Top Technologists Share Their Thoughts on Today's Technology Challenges

Unable to launch the ASP.NET Development Server because port ‘n’ is in use.

This error displays itself when trying to debug a Web Application or Web Service project from within Visual Studio 2005 and/or Visual Studio 2008 on machines running ESET NOD32 Antivirus.  This problem seems to occur every couple of months on our team, and for some reason we always go round and round trying to troubleshoot it, even though we’ve seen the fix numerous times, so I’m documenting it here again.

Step 1:

image

Double-click the NOD32 Antivirus link in your system tray.  Highlight “Setup” in the left pane and click “Antivirus and antispyware”

 

Step 2:

Click ConfigureU under Web access protection (see image above).

Step 3:

image

Select “Antivirus and antispyware” –gt; “Web access protection” –gt; “HTTP” –gt; “Web Browsers”  Find all of your devenv.exe instances in the list and click the check box next to them until a red x appears (image ).  Note: DO NOT make the box checked (image ) or the issue will continue!

 

Step 4:

Click “OK” and close NOD32.  You should now be able to launch the ASP.NET Development web server again without issue.

3 Comments. Leave new

HI . I HAVENOT NOD 32 OR ANY ANTIVIRUS BUT WHEN CLILCK RUN THEN MESSAGE SHOW : UNABLE TO LAUNCH THE ASP.NET DEVELOPMENT SERVER

Thank you very much for posting this! You saved me.

Thank You very much – I spent two hours before finding your post to resolve this!!!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>